Use Windows registered types

You have encountered a problem using Far Manager? Here you can get help.
Locked
dee
Posts: 8
Joined: Sun Dec 25, 2005 8:18 pm

Use Windows registered types

Post by dee » Sun Dec 25, 2005 8:42 pm

I'm getting strange behaviour when Use Windows registered types is on.
I guess it's caused by some ugly Microsoft hack, so I don't blame FAR.
But is there any simple workaround?

Reprocase:
1. install windows xp with service pack 2
2. install far 1.70 beta4
3. uninstall windows media player, so there is no windows association with .avi and all other video files
4. use explorer to associate .avi and other video formats with mplayer.
5. now clicking on test.avi or any other video format in explorer runs mplayer (good), but pressing enter on test.avi in far runs some windows wizard that tries to install windows media player (bad)

Dee

User avatar
t-rex
Admin
Posts: 417
Joined: Sun Mar 20, 2005 6:10 pm
Location: Ashdod
Contact:

Post by t-rex » Mon Dec 26, 2005 5:12 pm

Weird. I need to look at your registry settings for .avi. But any way you can use ShiftEnter when running avi files, it should work ok.

dee
Posts: 8
Joined: Sun Dec 25, 2005 8:18 pm

Post by dee » Sat Jan 07, 2006 1:28 pm

Shift Enter makes no difference from Enter.

After some reverse engineering work I found that
although Windows say that wmplayer is uninstalled,
HKEY_CLASSES_ROOT\.avi\ = "avifile"
which leads to
wmplayer lurking in
HKEY_CLASSES_ROOT\AVIFile\shell\play\command =
"C:\Program Files\Windows Media Player\wmplayer.exe" /prefetch:8 /Open "%L"

I can fix my problem by either changing "avifile" to anything else (which breaks link to lurking wmplayer) or changing command with wmplayer.

I don't know what is official place for storing file associations, but I found that reference to mplayer (that is used by explorer) is stored as
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.avi\Application = mplayer.exe

Dee

Locked