File Highlighting color problem

Here you can report bugs found in Far Manager.
Locked
JimWilson
Posts: 71
Joined: Thu Aug 18, 2005 5:32 pm

File Highlighting color problem

Post by JimWilson » Mon Feb 20, 2006 3:55 pm

I ran into an interesting bug. At least it appears to be a bug. I'm using 1.70 alpha 6 build 2069.

The machine I'm using at home, where I built my configuration, is Windows 2000 SP4. I have everything configured just so. Recently, I switched jobs. They gave me a desktop, also running Windows 2000 with SP4, and a laptop, running XP with SP2. In order to use my copy of FAR at work I zipped it all up and transferred it to a CD (pkzip -rP).

I installed it on both machines at work (pkzip -d) and then ran RestoreSettings. On the Windows 2000 desktop everything worked fine. However, on the XP system some of my colors in Files Highlighting where reset. Specifically, the Selected color for almost half of them (I only have about 10, so it's not a huge number).

What appeared to occur was that the Normal foreground color was somehow carried over into the Selected foreground color, so when I selected files the background color changed but not the foreground color (the foreground stayed the Normal color instead of the Selected color). While it only took me a few minutes to figure out what happened, and fix them, it was a bit odd that it only did that on the XP machine and not on 2000.

User avatar
t-rex
Admin
Posts: 417
Joined: Sun Mar 20, 2005 6:10 pm
Location: Ashdod
Contact:

Re: File Highlighting color problem

Post by t-rex » Tue Feb 21, 2006 12:41 am

JimWilson wrote:I ran into an interesting bug. At least it appears to be a bug. I'm using 1.70 alpha 6 build 2069.

The machine I'm using at home, where I built my configuration, is Windows 2000 SP4. I have everything configured just so. Recently, I switched jobs. They gave me a desktop, also running Windows 2000 with SP4, and a laptop, running XP with SP2. In order to use my copy of FAR at work I zipped it all up and transferred it to a CD (pkzip -rP).

I installed it on both machines at work (pkzip -d) and then ran RestoreSettings. On the Windows 2000 desktop everything worked fine. However, on the XP system some of my colors in Files Highlighting where reset. Specifically, the Selected color for almost half of them (I only have about 10, so it's not a huge number).

What appeared to occur was that the Normal foreground color was somehow carried over into the Selected foreground color, so when I selected files the background color changed but not the foreground color (the foreground stayed the Normal color instead of the Selected color). While it only took me a few minutes to figure out what happened, and fix them, it was a bit odd that it only did that on the XP machine and not on 2000.
Well, I think the problem is somewhere on your end, maybe not every thing was imported or exported from registry or something like that.

User avatar
t-rex
Admin
Posts: 417
Joined: Sun Mar 20, 2005 6:10 pm
Location: Ashdod
Contact:

Post by t-rex » Tue Feb 21, 2006 12:42 am

And are you sure that the XP machine did not have any previous settings in the Far registry key?

JimWilson
Posts: 71
Joined: Thu Aug 18, 2005 5:32 pm

Post by JimWilson » Wed Feb 22, 2006 2:11 am

t-rex wrote:Well, I think the problem is somewhere on your end, maybe not every thing was imported or exported from registry or something like that.
I thought of that possibility as well, so I ran ClearPluginsCache and the RestoreSettings a 2nd time. Made no difference -- the colors still didn't transfer. I played around with it some too, because I had never encountered that before, but it didn't change anything; those colors just weren't getting set properly. I even deleted Far's registry key manually before running RestoreSettings. But the results were still the same.
t-rex wrote:And are you sure that the XP machine did not have any previous settings in the Far registry key?
The laptop was a completely clean install, done by me directly from the XP CD, so there wasn't any possibility that Far was referenced in the registry before I installed it myself.

Locked