Crash when trying to Copy/Move files if run under Ceedo

Here you can report bugs found in Far Manager.
Locked
CyberWolf
Posts: 6
Joined: Wed May 09, 2007 10:28 am

Crash when trying to Copy/Move files if run under Ceedo

Post by CyberWolf » Wed May 09, 2007 10:57 am

Hy.

I've got a Lexar flash drive, and it comes with a very nice program called PowerToGo, it's actually a kind of "virtual computer" that you can have on the USB. The PowerToGo program is actually Ceedo modified to include the Lexar icons.
The address for Ceedo (in case you need it for the tests) is : www ceedo com (you get a 30 or 45 days trial version, or a full version if you buy a Lexar drive)

Sorry for the advertisments :D, anyways, when i try to run FAR manager under the Ceedo environment everything works fine until i try to copy or move a file in which case it crashes.
I've tryed to remove all plugins (tried with far /p too), tried different versions, the 1.70 and the alpha 3 build 2126 too.

My question is, what could i try to do so that i don't get this crash, as it's getting really annoying :o .
Note, on the same computer if i run FAR "normally" (not from Ceedo) it's working fine, so i suppose there's some incompatibility with Ceedo.

Here's the error i get with 1.70 Alpha 3 (build 2126):

Internal Error
Exception Occured :
"Attemp to read from inaccessible address 0x0"
Exception address : 0x6FB2C4DB in module :
D:\utilit\far\Far.exe
--------------------------
FAR Manager will be terminated!

P.S.
I've tried removing all FAR settings from registry and reinstalling it "cleanly", but still i get the same crash :(

HaRT
Posts: 100
Joined: Thu Mar 09, 2006 6:33 pm
Location: St. Petersburg, Russia

Post by HaRT » Thu May 10, 2007 11:32 am

CyberWolf
First of all, try to update from the link published here.
If it doesn't help, please use FExcept from FAR Manager 1.70 developer's pack to generate a trap log that will help developers to investigate the crash.

CyberWolf
Posts: 6
Joined: Wed May 09, 2007 10:28 am

Post by CyberWolf » Mon May 14, 2007 10:55 am

Hy
I've tried to install that version of FAR manager, and the same thing happens.

As for the FExcept it doesn't work under Ceedo, as in i get the "Internal Error Exception Occured" error message and not the one from FExcept, but works without problems in "normal" windows.

I'm beginning to think that it's some sort of problem with Ceedo and not FAR manager.

Anyways, thanx for the patience.

P.S. : I've tried it with the 2228 build too (from the russian forum) and get the same message.
I've found a way around the problem, i use the EMenu plugin and replaced the F5 with the Copy/Paste from Emenu and F6 with Cut/Paste from Emenu.
I know it's not the best ideea, but at least i can use FAR :D

EDIT :
I've done a few more tests, and there's something strange, if i install the Drag&Drop plugin and drag the files from one panel to the other, it works without problems, only that for some strange reason the files loose their "long file name".
I have no ideea if this is of any help, i just tought i'd share my findings.

CyberWolf
Posts: 6
Joined: Wed May 09, 2007 10:28 am

Fixed

Post by CyberWolf » Wed Jan 23, 2008 10:56 am

Hy.

I just wanted to let you know that the latest version of Ceedo has fixed some issues with the registry and FAR doesn't crash anymore. All versions i've tried work correctly (1.6, 1.7 even 1.8 ).

So, if anybody is using Ceedo and wanted to know if FAR would work with it, well, now it works :D

Locked